Back to overview
Sign-up is not working for users in New Zealand
Feb 10, 2025 at 12:10pm UTC
Affected services
it-ops.ai | homepage
Resolved
Feb 10, 2025 at 12:10pm UTC
All services are working correctly
Affected services
Resolved
Feb 10, 2025 at 12:10pm UTC
All services are working correctly
Affected services